Computerspieler-Test - "Wartet seit 1461 Sekunden"

TheJH
Beiträge: 3
Registriert: Sa 13. Aug 2011, 23:06

Computerspieler-Test - "Wartet seit 1461 Sekunden"

Beitragvon TheJH » Fr 10. Feb 2012, 16:04

Hallo,
was bedeutet es, wenn in der Computerspieler-Übersicht "Wartet seit 1461 Sekunden" steht? Worauf wird gewartet? Auf eine Warteschlange? Auf einen Spielzug? Und ist so eine lange Dauer normal? Ich fände es wirklich gut, wenn das funktionieren würde...

ChristianR
Beiträge: 17
Registriert: So 6. Nov 2011, 13:33

Re: Computerspieler-Test - "Wartet seit 1461 Sekunden"

Beitragvon ChristianR » So 12. Feb 2012, 15:17

Bei mir tritt derzeit das gleiche Problem auf.

Hoffentlich passiert das nicht kurz vor Beginn der Wettkampfphase.

TheJH
Beiträge: 3
Registriert: Sa 13. Aug 2011, 23:06

Re: Computerspieler-Test - "Wartet seit 1461 Sekunden"

Beitragvon TheJH » So 12. Feb 2012, 17:06

Sooo... "Wartet seit 178010 Sekunden"... das ist wirklich ziemlich viel. Und auch ein Freitag gestartetes Spiel ist noch am Anfang ("Läuft (0 / 6)").

Benutzeravatar
Christian Wulf
Beiträge: 27
Registriert: Mi 31. Aug 2011, 05:54

Re: Computerspieler-Test - "Wartet seit 1461 Sekunden"

Beitragvon Christian Wulf » So 12. Feb 2012, 18:20

Ich leite das mal weiter.

ChristianR
Beiträge: 17
Registriert: So 6. Nov 2011, 13:33

Re: Computerspieler-Test - "Wartet seit 1461 Sekunden"

Beitragvon ChristianR » Mo 13. Feb 2012, 10:13

Insgesamt scheint sich allerdings noch was zu tun. Als ich heute morgen bei der Wettkampfseite vorbeigeschaut habe, sind die Tests durchgelaufen.

ChristianR
Beiträge: 17
Registriert: So 6. Nov 2011, 13:33

Re: Computerspieler-Test - "Wartet seit 1461 Sekunden"

Beitragvon ChristianR » Di 14. Feb 2012, 18:39

Ich versuche derzeit eine zweite KI-Version zu testen. Inzwischen bin ich bei 114830 Sekunden Wartezeit angelangt. Kann es sein, dass die VMs komplett überlastet sind?

Mir ist übrigens bei den Testspielen der ersten KI-Version etwas Mysteriöses aufgefallen. Das Log hat folgenden Grund für das vorzeitige Abbrechen des Spiels geliefert:
Das Spiel wurde von der KI regelkomform zu Ende gespielt. HARD_TIMEOUT des Gegners.


Die KI ist hierbei meine KI-Version, der Gegner der SimpleClient, gegen den die KI getestet wird. Wenn die Log-Implementation nicht falsch ist (ich habe sie nochmal durchgeschaut, sieht aber vernünftig aus), könnte das heißen, dass während des Testdurchlaufs die Verbindung des Servers zum SimpleClient abgerissen ist.

Anmerkend: Der andere Testdurchlauf führte wie erwartet zu einem verfrühten Abbruch des Testspiels durch ein Soft_Timeout von Seiten der KI aus. Die erste KI-Version überschreitet derzeit noch regelmäßig die 2 Sekunden-Grenze (siehe Thread "Java und der GC"). Hier war die entsprechende Ausgabe:

SOFT_TIMEOUT der KI. Das Spiel wurde von dem Gegner regelkomform zu Ende gespielt.

chst
Beiträge: 18
Registriert: Mo 14. Mär 2011, 12:25

Re: Computerspieler-Test - "Wartet seit 1461 Sekunden"

Beitragvon chst » Mi 15. Feb 2012, 15:13

Moin,
danke für Deine Rückmeldungen! Zur Zeit lassen wir 3 Test-Wettkämpfe laufen, um den Ernstfall zu proben. Dadurch kommt es gelegentlich zu Wartezeiten.

In Zukunft werden wir im Wettkampfsystem oben unter "Aktuelles" einen Hinweis eintragen, wenn Testwettkämpfe laufen.

Freundliche Grüße
Christoph

ChristianR
Beiträge: 17
Registriert: So 6. Nov 2011, 13:33

Re: Computerspieler-Test - "Wartet seit 1461 Sekunden"

Beitragvon ChristianR » Sa 18. Feb 2012, 11:20

Derzeitiger Stand: "Wartet seit 434701 Sekunden"

Seit über einer halben Woche tut sich leider nichts mehr. :(

chst
Beiträge: 18
Registriert: Mo 14. Mär 2011, 12:25

Re: Computerspieler-Test - "Wartet seit 1461 Sekunden"

Beitragvon chst » Do 23. Feb 2012, 13:44

Moin,
die virtuellen Maschinen hatten sich leider heimlich aufgehängt. Seit einigen Tagen sollte es allerdings, abgesehen von gelegentlichen Test-Wettkämpfen, die unter "Aktuelles" angekündigt werden, keine Behinderungen mehr geben.

Freundliche Grüße
Christoph

ChristianR
Beiträge: 17
Registriert: So 6. Nov 2011, 13:33

Re: Computerspieler-Test - "Wartet seit 1461 Sekunden"

Beitragvon ChristianR » Do 23. Feb 2012, 18:30

Danke für die Rückmeldung.

Inzwischen laufen die Tests auch problemlos. ;)