Fehler im simple client main.rb

wollw
Beiträge: 31
Registriert: Mi 16. Mär 2011, 21:43

Fehler im simple client main.rb

Beitragvon wollw » So 10. Jan 2016, 00:44

Beim Testen eines hochgeladenen Clients wird von der virtuellen Maschine der Befehl ausgeführt:

Startup command: ./main.rb --host 192.168.56.2 --port 13050 --reservation e06b8ce7-1ca4-45ae-af07-4ea86f684747

Ein Blick auf die Datei main.rb zeigt, dass die option --reservation nicht implementiert ist.
Kai Wollweber
Peter-Ustinov-Schule
Eckernförde

SvenK
Beiträge: 114
Registriert: Mo 17. Okt 2011, 08:40

Re: Fehler im simple client main.rb

Beitragvon SvenK » Mo 11. Jan 2016, 14:12

Das wird in den naechsten Tagen in einer neuen Version des Ruby Clients behoben sein.

SvenK
Beiträge: 114
Registriert: Mo 17. Okt 2011, 08:40

Re: Fehler im simple client main.rb

Beitragvon SvenK » Mo 11. Jan 2016, 14:42

Die neue Version steht jetzt bereit.

SvenK
Beiträge: 114
Registriert: Mo 17. Okt 2011, 08:40

Re: Fehler im simple client main.rb

Beitragvon SvenK » Di 12. Jan 2016, 08:11

Es gibt noch Probleme mit dem Zugriff auf das software_challenge_client Gem im Wettkampfsystem. Ich arbeite dran...

SvenK
Beiträge: 114
Registriert: Mo 17. Okt 2011, 08:40

Re: Fehler im simple client main.rb

Beitragvon SvenK » Di 12. Jan 2016, 14:26

Jetzt funktioniert alles. Es geht allerdings nur auf der neuen VM, auf der alten ist nur Ruby 1.8 installiert.

wollw
Beiträge: 31
Registriert: Mi 16. Mär 2011, 21:43

Re: Fehler im simple client main.rb

Beitragvon wollw » So 17. Jan 2016, 18:46

Von uns aus funktioniert das Hochladen und Testen von Ruby-Programmen nicht. Weder mit unserem Client noch mit dem unveränderten Simple Client.

Zur Dokumentation habe ich den simple client (Dateien client.rb und main.rb) aus dem aktuellen Gem software_challenge_client 0.1.5 in eine ZIP-Date gepackt (Datei simpleclient.zip) und unter dem Namen "simpleclient" hochgeladen, Hauptdatei "main.rb" sowie VM "Neu" eingestellt und anschließend "testen" geklickt.

Die Statusanzeige beginnt mit "Testet seit ... Sekunden", wechselt später auf "Wartet seit ... Sekunden". Die Zustände "Testet" und "Wartet" wechseln mehrfach, ohne dass der Prozess endet. Mittlerweile heißt es "wartet sei 3875 Sekunden". Ob der Prozess noch zum Ende kommt, bleibt abzuwarten. Von mir aus werde ich den Prozess bis morgen nicht abbrechen.

Unter Details -> Logfiles -> Tests sind keine Log-Dateien verfügbar.

Falls das Problem gelöst ist, wäre es wünschenswert, wenn in der allgemeinen Dokumentation unter "Client abgabefertig machen" auch eine kurze Anleitung für die Ruby-Version gestellt wird.
Kai Wollweber
Peter-Ustinov-Schule
Eckernförde

SvenK
Beiträge: 114
Registriert: Mo 17. Okt 2011, 08:40

Re: Fehler im simple client main.rb

Beitragvon SvenK » Mo 18. Jan 2016, 12:35

Es gab noch Probleme durch das Aktivieren der Freundschaftsspiele. Jetzt sollte aber alles wieder laufen. Ich habe eben den Test Ihres hochgeladenen Test-Clients nochmal gestartet und er ist korrekt durchgelaufen.

Die Doku werde ich jetzt noch ergaenzen, danke fuer den Hinweis!

SvenK
Beiträge: 114
Registriert: Mo 17. Okt 2011, 08:40

Re: Fehler im simple client main.rb

Beitragvon SvenK » Mo 18. Jan 2016, 13:42